cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1166
Views
15
Helpful
5
Replies

Bandwidth command & QoS

johnny_5
Level 1
Level 1

Inherited a remote branch that has a 10MB circuit from ISP. There is a need to increase it to 20MB. 

 

With respect to the router (2911)config does the bandwidth command need to be edited to reflect the new increased bandwidth? Below is what is currently configured. I also have a QoS applied to the interface, does the shape average have to be edited also?

 

interface GigabitEthernet0/0
description ATT-MPLS-PE
bandwidth 10000
no ip address
no ip redirects
no ip proxy-arp
duplex full
speed 100
!
interface GigabitEthernet0/0.50
description ATT-MPLS 
bandwidth 10000
encapsulation dot1Q 50
ip address x.x.x.x
ip flow ingress
ip flow egress
service-policy input QoS_IN
service-policy output QoS_OUT_Parent

 

policy-map QoS_OUT
class VOIP
set ip dscp ef
priority percent 40


class INFRA_EGRESS
police cir percent 40
conform-action transmit
exceed-action drop
class class-default
queue-limit 1536 packets


policy-map QoS_OUT_Parent
class class-default
shape average 10000000
service-policy QoS_OUT
policy-map QoS_IN


class EMAIL_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop


class WEBSERVER_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop


class INFRA_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop

5 Replies 5

Hello,

 

if you want to use the 'bandwidth' command for QoS purposes, add 'qos-reference'. The shaper needs to be adjustedif you increase the bandwidth:

 

interface GigabitEthernet0/0
description ATT-MPLS-PE
--> bandwidth qos-reference 20000
no ip address
no ip redirects
no ip proxy-arp
duplex full
speed 100
!
interface GigabitEthernet0/0.50
description ATT-MPLS
--> bandwidth qos-reference 20000
encapsulation dot1Q 50
ip address x.x.x.x
ip flow ingress
ip flow egress
service-policy input QoS_IN
service-policy output QoS_OUT_Parent
!
policy-map QoS_OUT
class VOIP
set ip dscp ef
priority percent 40
!
class INFRA_EGRESS
police cir percent 40
conform-action transmit
exceed-action drop
class class-default
queue-limit 1536 packets
!
policy-map QoS_OUT_Parent
class class-default
--> shape average 20000000
service-policy QoS_OUT
policy-map QoS_IN
!
class EMAIL_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop
!
class WEBSERVER_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop
!
class INFRA_INGRESS
police cir percent 20
conform-action transmit
exceed-action drop

What exactly does the command you provided change from what it is currently set at?

 

bandwidth qos-reference 20000

Hello @johnny_5 ,

Georg has provided you the commands to update the configuration of the router to reflect the new speed 20 Mbps.

 

you can use the bandwidth 20000   to change the bandwdith parameter of interfaces and subinterfaces (it is expressed in Kbps)

You need also to update the shaping rate of the parent QoS shaper policy-map.

 

the child policy will inherit the BW command from the parent policy

 

Hope to help

Giuseppe

 

So was the config that is currently applied not correct? Does using the bandwidth command on its own not have the same effect as bandwidth qos reference?

Joseph W. Doherty
Hall of Fame
Hall of Fame
One critical value to change is the shaper's value (as already noted by Georg and Giuseppe). (NB: this should also impact the implicit egress LLQ's policer.)

Policy-maps also usually "pick up" bandwidth from interface's bandwidth statement (as already noted by Giuseppe), as do some routing protocols, so you might just change your bandwidth statements without using the explicit QoS option (noted by Georg). Whichever you use, though, is also critical to adjust the bandwidths calculated by the policers used within the ingress policy.
Review Cisco Networking products for a $25 gift card