cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
532
Views
0
Helpful
4
Replies

configure a cisco ir 809 to have internet from zero

atlascorpcod
Level 1
Level 1

Hello i need to configure a cisco router 809 with Putty as a cisco IOT but i am not even capable to configure the system to have internet , i have tried several tutorials but nothing

1 Accepted Solution

Accepted Solutions

atlascorpcod
Level 1
Level 1

this has been the typical configuration that i have tried many times 

 

 

cell 0 create 1 lte profile # Create a cellular profile
ipv4 primary dns-server 8.8.8.8 # Replace with your preferred IPv4 DNS server
ipv6 primary dns-server 2001:4860:4860::8888 # Replace with your preferred IPv6 DNS server
exit

interface Cellular0
ip address negotiated
ip nat outside
encapsulation slip
dialer in-band
dialer string your-APN-name-here # Replace with your carrier's APN
dialer-group 1
async mode interactive
lte profile 1 # Apply the cellular profile created earlier
exit

interface GigabitEthernet0 # This is for LAN connectivity
ip address 192.168.1.1 255.255.255.0 # Replace with your LAN IP details
ip nat inside
exit

interface GigabitEthernet1 # This is for WAN connectivity (Internet)
ip address dhcp # Assuming it's a DHCP connection from your ISP
ip nat outside
exit

access-list 1 permit 192.168.1.0 0.0.0.255 # Replace with your internal network details

ip dhcp excluded-address 192.168.1.1 # Exclude the router's LAN IP from DHCP pool
ip nat inside source list 1 interface Cellular0 overload
ip nat inside source list 1 interface GigabitEthernet1 overload # For WAN connection

ip route 0.0.0.0 0.0.0.0 GigabitEthernet1 # Set the default route to use Gig1 for internet

ip dhcp pool LAN
network 192.168.1.0 255.255.255.0 # Specify your LAN network range
default-router 192.168.1.1 # Default gateway for DHCP clients
dns-server 8.8.8.8 # Replace with your preferred DNS server
exit

View solution in original post

4 Replies 4

atlascorpcod
Level 1
Level 1

this has been the typical configuration that i have tried many times 

 

 

cell 0 create 1 lte profile # Create a cellular profile
ipv4 primary dns-server 8.8.8.8 # Replace with your preferred IPv4 DNS server
ipv6 primary dns-server 2001:4860:4860::8888 # Replace with your preferred IPv6 DNS server
exit

interface Cellular0
ip address negotiated
ip nat outside
encapsulation slip
dialer in-band
dialer string your-APN-name-here # Replace with your carrier's APN
dialer-group 1
async mode interactive
lte profile 1 # Apply the cellular profile created earlier
exit

interface GigabitEthernet0 # This is for LAN connectivity
ip address 192.168.1.1 255.255.255.0 # Replace with your LAN IP details
ip nat inside
exit

interface GigabitEthernet1 # This is for WAN connectivity (Internet)
ip address dhcp # Assuming it's a DHCP connection from your ISP
ip nat outside
exit

access-list 1 permit 192.168.1.0 0.0.0.255 # Replace with your internal network details

ip dhcp excluded-address 192.168.1.1 # Exclude the router's LAN IP from DHCP pool
ip nat inside source list 1 interface Cellular0 overload
ip nat inside source list 1 interface GigabitEthernet1 overload # For WAN connection

ip route 0.0.0.0 0.0.0.0 GigabitEthernet1 # Set the default route to use Gig1 for internet

ip dhcp pool LAN
network 192.168.1.0 255.255.255.0 # Specify your LAN network range
default-router 192.168.1.1 # Default gateway for DHCP clients
dns-server 8.8.8.8 # Replace with your preferred DNS server
exit

are you usign cellular or ethernet for internet connectivity ?

 

 

Hello @atlascorpcod,

Do you receive IP add. on interface Wan Gig0/1 ?

From router, try ping 8.8.8.8.

On router you have a sim card inserted? Or does Giga 0/1 is your only WAN out interface?

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

nipun043
Cisco Employee
Cisco Employee

how are you connecting it to your service provider ? do you have cellular or rj45 connection ? can you pls provide more details on what you are trying to do ?