This app is incompatible with your device (OnePlus One)

Hi everyone,

I do have a OnePlus One smartphone running Android 5.0.2 and I am unable to download Duo Mobile App from Google Play Store. The message showed is the following: “This app is incompatible with your device.”
My College demands me to get this specific app to secure my account and I am unable to do it.

Can somebody help me fix this issue?

I look forward to your responses
Thanks a lot

Maggle

Hi there. We do not provide official support for OnePlus devices and, since Android 5.0.2 is old and also unsupported, you may not be able to download the app via the Play Store. However, you can find the Duo Mobile APK in this Knowledge Base article: https://help.duo.com/s/article/2211 However, you may run in to compatibility issues.

If your college allows you to complete two-factor authentication with phone calls or SMS-delivered passcodes, you do not need to download the Duo Mobile app in order to complete authentication.

1 Like

Thanks a lot for your prompt response !
Wish you a nice day