Suddenly, it doesn't work

Hi duo,
Until 7, June, duo push worked well.
But duo push’s failed with location unknown message today.
I recently changed some options from Android cell phone.
But I’m not sure what it is cuz I just followed guides from youtube.
Are location unknown messages related to location unknown?
Location service is enabled.
I tried to recover previous settings. But all failed.
I want to know what of Android process must be activated.
thank you
best regards

Hi @jsk,
Welcome to the Community! Thanks for sharing your question here with us. I think I may know what’s going on here, but it would help if you could provide a bit more information please. Where are you seeing the location unknown message? Also, which guides from YouTube are you referring to that you used to make these changes? If you can share the exact changes you made, that would be helpful as well.

It sounds to me like you may have changed some device settings with your Android phone that caused the Duo Mobile app to deactivate, and you should be able to authenticate again once you follow the steps to reactivate the app. If you are accessing an application that displays the Duo Prompt and your administrator has enabled the self-service portal, you can follow the steps here to reactivate Duo Mobile. Otherwise, ask your administrator to send you a new activation link.

Hi Duo,

I changed some options from Android between 7th and 14th.
So I’ve believed the reason Duo doesn’t work is due to Android options.


Youtube URL is below. Please use subtitle options of Youtube.com.
[이게 켜져 있으면 내 정보 밤새 다 빠져나갑니다!! 휴대폰 설정 4가지 무조건 꺼 놓으세요! - YouTube]
I trying to recover those options but the result is the same.
thank you
best regards

Hi Jsk,

Thanks for sharing the video you watched with us. I took a look at it using subtitles, and none of those settings will impact the functionality of Duo Mobile. Please refer to this article for which device permissions Duo Mobile for Android needs for confirmation.

You just need to reactivate Duo Mobile. In the guide to reading the Authentication Log in the Duo Admin Panel, it states:

A Second Factor result of Unknown indicates that a user enrolled but did not activate a mobile device, or the user canceled the push request. In either case, no data about a second factor could be retrieved from a device.

Please reactivate Duo Mobile using the steps I shared above in my previous comment, and let us know if that resolves your issue. Thanks!

Hi Amy,
Thank you for advice.
I realized an account of DUO-PROTECTED had been disabled on the DUO app.
I don’t know why.
As you said, I tried to re-activate my cell phone on Phones menu of 2FA Devices and
it worked well.
thank you very much!
best regards.

1 Like

Glad you were able to get it working again! Your Duo-protected accounts can get disconnected for a number of reasons, some of which are covered in this help article. It’s possible that the act of changing your device settings could have triggered this to occur. Reactivating always solves it though. Again, I’m happy to hear it’s working for you now!