RemoteApp Not Launching with Duo for RDG Installed

I have a new RemoteApp server and tried to launch an app. I get the RDG prompt, I enter my credentials, Duo pings me, I approve the access and, after it successfully logs in, get an error that says “Windows cannot start the RemoteApp program. The following RemoteApp program is not in the list of authorized programs: <any published program, e.g., Calculator>. For assistance, contact your system administrator.”

I originally thought it was a RemoteApp problem and contacted Microsoft since Duo did authenticate just fine. They pointed out their log shows it’s a problem with Duo.

So, I build a new RDG/RDCB/RDW without installing Duo for RDG and I was surprised that RemoteApp worked flawlessly.

I do have a ticket opened with Duo on this very issue but I wanted to let everyone searching for solution to the same problem that I’ll post here what the solution is. I did search the forum and didn’t find a solution. I am aware that RemoteApp is disabled when Duo for RD Web is installed but I only installed Duo for RD Gateway, not Duo for RD Web, so that one does not apply to me. Wish me luck!

Thanks for sharing this here, John! I’ll be interested to hear what you and the support team find out.

So, the first response was to send me a link about RD Web, and I replied back that I do not have Duo for RD Web but, rather, Duo for RD Gateway. It went without any replies for a couple of days then I had to phone it in. Apparently, was miscategorized but, once fixed, they got on the ball.

  1. Asked me to uninstall Duo for RDG and try publishing. I did that and that didn’t work.

  2. I told them I was going to build a new RDG/RDCB/RDW/RDL without Duo. The published app was able to be successfully launched outside of my LAN. I then installed Duo for RDG and the published app was still able to launch just fine.

I told them that I suspect I’ll have to rebuild a new RDG/RDCB/RDW/RDL every time I want to publish a new app. They then added my account to the existing request to improve this portion of Duo but they explained that this has been de-prioritized due to some legacy components in there. Then they closed my case. End of story.

I hope I don’t need to publish any new apps for a while. At least there’s a solution although a lot of work to rebuild a new RDG/RDCB/RDW/RDL.