Remote Desktop Connection Manager on server with Duo - "Ordinal not found"

I tried that work around, and while it fixed that issue, it caused a different problem with our RemoteApp server, where we had to enter our credentials twice to get the apps to launch.

Any update on a permanent fix would be great, since I’ve been following this topic for a couple months now.

September 10 - we’re a new Duo customer and are also experiencing this issue. Any update?

So, I was able to get this resolved. This is from memory so hopefully I am getting this right.

I solved this by going to the root of the Remote Desktop Conenction manager, in the left pane, right click on your server group, properties, Logon Credentials.

Under profile, select “Custom” and enter your current credentials, and save over the existing profile or save it with a new name. Select the profile you just saved. Try logging on to a system,

In Remote Desktop Connection Manager, save your RDG session. You may have still get the error ONCE after doing this, click through it, log on and save your RDG session AGAIN.

This ordinal error pops up every time I change credentials and have to do this.

Just noting that I have Server 2016 with 3.1.2 installed and am still getting the ‘ordinal 381’ error. I get it with RDCMan or with a straight RDP session when I run an application on the remote session as an administrator.

We are planning to roll out Duo to several hundred additional servers but our engineers are pushing back due to this bug. Is there an update or possible timeline for a fix for this issue?

This fixed it for me. Thanks, cwilson!

[Update] I tried version 4.0.0 and it is still giving the error, so it has not been fixed. . .

I just installed version 4.0.0 today, and so far, things are looking fixed when I try to connect using Terminals.

Is there a resolution for this that does not involve saving credentials in RDCMan?

This is affecting my team as well. @PatrickKnight can you at least give an update regarding the priority review you mentioned nine months ago?

We’re seeing the same issue here on machines running mstsc against Windows 2016 servers.

As the issue has been around for 9 months and several DUO releases, is there a fix in the pipeline ?

Not a good initial customer experience for my staff !

Hello, we are getting this error when attempting to use Virtual Machine Manager attempting to connect to virtual machine’s consoles on other domains.

Just to confirm this is still a problem. I even tried to save the profile over again and it still pops up twice on each connection.

Same issue for us (using ASG 2019 x64) with the latest Duo version (4.0.3).

Any idea when it’s likely to be fixed?

I was doing a Google search cause I was running into the same issue. I’d like to add my two cents that I believe could be useful. I’m noticing a trend that briefly reading through the previous comments I don’t think has been pointed out yet. Maybe just an issue w/ the remote clients that run Windows 10?

  • Same error Ordinal not found.
  • Host is using Windows Server 2016
  • We use Dou to access the host.
  • What I’ve noticed…
    — Is that the clients running Windows 7 Enterprise are not affected by this.
    — However remote clients running Windows 10 Enterprise are affected.

Hope this helps!

Hi, was this ever fixed? running into this with Remote desktop connection manager.

Hey y’all quick update. We’ve identified the issue and a fix will be included in the next release, release date TBD but I’ll post here again with an update as it gets closer to release.

After over a year I resigned myself to this never getting fixed. Glad it finally made it to the release schedule! Thanks for the update.

We had the same issue and we found that by inheriting credentials from parent from the logon credential tab was fixing the issue.
But I must admit that it’s less secure

We’re targeting the end of the quarter to have new release out that will resolve the ordinal issue.

On 2 August DUO was new release and I don’t see any fix for this issue.
PatrickKnight - could you comment this?