Remote Desktop Connection Manager on server with Duo - "Ordinal not found"


We installed Microsoft’s Remote Desktop Connection Manager on a terminal server with Duo authentication installed so we can RDP into other servers from that box. Everything worked great until we rebooted the server, and now every time we try to make an RDP connection to another server using RDCMan, we get this error message multiple times:

“The ordinal 379 could not be located in the dynamic link library C:\Program Files\Duo Security\WindowsLogon\DuoCredProv.dll”

If you click through the multiple warnings RDCMan connects to the remote server,

Anyone seen this before? Any way to resolve it?



Hi Texx,

This is a known issue and are reviewing priority for a fix.

Can you let me know what version of Winlogon and Windows are you running?



Thanks Patrick, at least it’s a known issue.

We’re on Windows version 2012R2, and Winologin 3.1.1


We are experiencing the same issue. Windows Server 2016 (build 1607) and


We’re about to update to Server 2016, so thanks for confirming the issue is still present. Let’s hope Duo can get this resolved in the next release.


This fix is not slated for release in our next update. We’re investigating it for the following release however.


Just want to add that I have same issue, though ordinal # in my error is 381. Duo was just installed on my laptop. I am using RDCMan on Windows 10 v1709 with Windows updates through 3/30/2018. I use RDCMan to connect to Windows Server 2008 R2 through 2016.


Our error is 379 for the ordinal. Windows Server 2012 rds host protected by DUO using an RDG file to jump to other servers (Very common for AWS.)

We get this error when opening Remote Desktop Connection Manager via the RDG file. We do NOT get the error if we open Remote Desktop Connection Manager and THEN open the RDG file.


Same issue using rdc manager on Windows server 2016 . Ordinal 381 could not be located …DuoCredProv.dll


Any update on a targeted fix for this. This is a large problem for our entire IT staff.


I experienced same issue with Duo version 3.12.412, and found a work around.
Just replace the DuoCredProv.dll with the one from old version


I tried that work around, and while it fixed that issue, it caused a different problem with our RemoteApp server, where we had to enter our credentials twice to get the apps to launch.

Any update on a permanent fix would be great, since I’ve been following this topic for a couple months now.


September 10 - we’re a new Duo customer and are also experiencing this issue. Any update?


So, I was able to get this resolved. This is from memory so hopefully I am getting this right.

I solved this by going to the root of the Remote Desktop Conenction manager, in the left pane, right click on your server group, properties, Logon Credentials.

Under profile, select “Custom” and enter your current credentials, and save over the existing profile or save it with a new name. Select the profile you just saved. Try logging on to a system,

In Remote Desktop Connection Manager, save your RDG session. You may have still get the error ONCE after doing this, click through it, log on and save your RDG session AGAIN.

This ordinal error pops up every time I change credentials and have to do this.


Just noting that I have Server 2016 with 3.1.2 installed and am still getting the ‘ordinal 381’ error. I get it with RDCMan or with a straight RDP session when I run an application on the remote session as an administrator.


We are planning to roll out Duo to several hundred additional servers but our engineers are pushing back due to this bug. Is there an update or possible timeline for a fix for this issue?


This fixed it for me. Thanks, cwilson!


[Update] I tried version 4.0.0 and it is still giving the error, so it has not been fixed. . .

I just installed version 4.0.0 today, and so far, things are looking fixed when I try to connect using Terminals.


Is there a resolution for this that does not involve saving credentials in RDCMan?


This is affecting my team as well. @PatrickKnight can you at least give an update regarding the priority review you mentioned nine months ago?