RDP on Win10: Password entry 2x required


#1

Hi,

we use duosecurity for RDP Sessons. On Windows 10 we have the issue (since about 1 month), that the user is required to enter the password 2 times.

Once in the Windows 10 mstsc.exe UI (screenshot: above) and then in the remotedesktop Session before the Duosecurity UI is shown (screenshot below):

Update to the current Version of DuoSecurity didn’t help.
It wasn’t the case about 1 month ago - it worked fine then with only 1x password input.

This could have something to do with:

  • windows 10 Creators Update
  • Windows Components/Remote Desktop Services/Remote Desktop Connection Client/Do not allow passwords to be saved Enabled (GPO)
  • Control Panel/Personalization/Enable screen saver (GPO)
    Enable screen saver Enabled
    Force specific screen saver Enabled Screen saver executable name %windir%\system32\rundll32.exe user32.dll,LockWorkStation
    Password protect the screen saver Enabled
    Screen saver timeout Enabled 900

Please advice how to solve this annoying issue…


#2

@MGR This is a known issue were are currently investigating around the Fall Creators v1709 release. We will shared updates as soon as they are available.


#3

@PatrickKnight thank you for the information