RDP not asking for push

Hi I have installed duo on other servers prior 2019 and worked great, I have tried installing it on a new 2019 rdp server without AD just remote desktop services, after installing and rebooting the server I get no duo push notifications and the users login automatically, I have enrolled the users also in the admin panel, can anyone help? I also do not see any duo process running in the task manager or in the services.

Regards

Also if I go in services of other server I see a service called dmwappushservice which I suppose it should be duo mobile windows app push service, but in the 2019 the service is never created, I have tried also running the setup as administrator without any luck (run as administrator)

Regards

The “dmwappushservice” service is the Windows “Device Management Wireless Application Protocol” service, and is not a Duo component or one used by the installed Duo application.

Try enabling debug logging for Duo for Windows Logon and then review the log to see what is happening when users log in to the system.

I also do not see any duo process running in the task manager or in the services.

That is correct; the Duo for Windows Logon credential provider is only invoked during the logon or credentialed UAC elevation event and does not run persistently in the background of a user session.

Hi thanks I reviewd the log and saw that it will not protect rdp, I tried reinstalling again and this time did not cheked the UCA options now is working.

Regards