Problems installing Duo for Linux

Hello,

When I attempt to install Duo for Linux, I’m getting these errors:

make[2]: Entering directory ‘/home/administrator/duo_unix-1.11.4/compat’
depbase=echo groupaccess.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||';
/bin/bash …/libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I… -g -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -MT groupaccess.lo -MD -MP -MF $depbase.Tpo -c -o groupaccess.lo groupaccess.c &&
mv -f $depbase.Tpo $depbase.Plo
libtool: compile: Failed to create `.libs’
Makefile:382: recipe for target ‘groupaccess.lo’ failed
make[2]: *** [groupaccess.lo] Error 1
make[2]: Leaving directory ‘/home/administrator/duo_unix-1.11.4/compat’
Makefile:472: recipe for target ‘all-recursive’ failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory ‘/home/administrator/duo_unix-1.11.4’
Makefile:382: recipe for target ‘all’ failed
make: *** [all] Error 2
administrator@ZMTEST:~/duo_unix-1.11.4$

It also seems that /etc/duo directory is not getting created, as the install is unsuccessful. Can someone please give me an idea of what I’m doing wrong? Thanks.

Hi,

Which Linux distribution do you use? Have you tried with sudo or as root?

Regards,
Antony

1 Like

Hi Antony,

Thanks for the response. I have tried using Sudo, and the distro I’m on is Ubuntu 16.04. Thanks.

Hi Patrick,

Can you share the output of a ls -ld? It seems there is an issue with permission in your directories.

Regards,
Antony

Could the issue be which directory I’m uncompressing the tar file in? I’m uncompressing it under /home/administrator. I’m wondering if that’s causing the permissions issue?

administrator@ZMTEST:~$ cd duo_unix-1.11.4/
administrator@ZMTEST:~/duo_unix-1.11.4$ ls -ld
drwxr-xr-x 9 root root 4096 Nov 9 09:53 .
administrator@ZMTEST:~/duo_unix-1.11.4$

Patrick,

It is indeed the issue:

  • the directory belongs to root
  • you run the command as administrator
  • libtool tries to create a .libs directory where it may not.

Which command did you use to extract the files from the archive?

Normally, you should use the following commands:

  1. tar zxf duo_unix-latest.tar.gz
  2. cd duo_unix-1.11.4
  3. ./configure --with-pam --prefix=/usr && make && sudo make install
    /!\Pay attention the sudo is only used with the make install /!\

I did that successfully on a Debian box (so, kinda the same architecture than Ubuntu).

Regards,
Antony

Thank you for help Antony. I was able to get it to install after trying this as root as opposed to running it with sudo under my Administrator login.

image001.png

Hi Patrick,

Glad you found the way to install it.

As I said in my previous reply, sudo is only used during the installation phase and during the compiling phase. You need to pay attention to that in Linux:

  1. If you don’t, you may have permission issues as you had here.
  2. It is not recommended to use root (sudo) privilege when it is not needed.
    If, by any chance, there is a typo in the script, you could end in a f*** up system. You may find a lot of article on the web about this.

HTH,
Antony