Parallels remote application server

Trying to setup OTP with Parallels RAS.
When I enter credentials and the PIN I get : Access denied Wrong Username or password.
The log shows the bellow :
2020-03-28T16:10:14+0200 [DuoForwardServer (UDP)] Sending request from 10.2.0.130 to radius_server_auto
2020-03-28T16:10:14+0200 [DuoForwardServer (UDP)] Received new request id 1 from (‘10.2.0.130’, 49211)
2020-03-28T16:10:14+0200 [DuoForwardServer (UDP)] ((‘10.2.0.130’, 49211), ioannisv, 1): login attempt for username u’ioannisv’
2020-03-28T16:10:14+0200 [DuoForwardServer (UDP)] u"Sending AD authentication request for ‘ioannisv’ to ‘10.2.0.101’"
2020-03-28T16:10:14+0200 [duoauthproxy.modules.ad_client._ADAuthClientFactory#info] Starting factory <duoauthproxy.modules.ad_client._ADAuthClientFactory object at 0x03020E90>
2020-03-28T16:10:15+0200 [_ADAuthClientProtocol,client] LDAP Authentication Failed: ‘invalidCredentials: 8009030C: LdapErr: DSID-0C09056D, comment: AcceptSecurityContext error, data 52e, v2580\x00’
2020-03-28T16:10:15+0200 [_ADAuthClientProtocol,client] ((‘10.2.0.130’, 49211), ioannisv, 1): Primary credentials rejected - User Authentication Failed
2020-03-28T16:10:15+0200 [_ADAuthClientProtocol,client] ((‘10.2.0.130’, 49211), ioannisv, 1): Returning response code 3: AccessReject
2020-03-28T16:10:15+0200 [_ADAuthClientProtocol,client] ((‘10.2.0.130’, 49211), ioannisv, 1): Sending response
2020-03-28T16:10:15+0200 [duoauthproxy.modules.ad_client._ADAuthClientFactory#info] Stopping factory <duoauthproxy.modules.ad_client._ADAuthClientFactory object at 0x03020E90>

Could someone advise ?

The upstream LDAP server is rejecting the provided credentials as incorrect. Take a look at your directory server’s events, and double-check your password.

You can also enable debug logging on the Duo proxy server for more details.

Here’s a guide to interpreting the Duo Authentication Proxy debug output.