No Accounts Found on Apple Watch 6

Dear Community,

I have 2 accounts in my Duo Mobile app in my iPhone, now I have an Apple Watch and installed Duo there, but I’m getting the message “No Accounts Found, Please open Duo Mobile in your iPhone”. I have opened the app, rebooted the phone, the watch, and nothing seems to work… the accounts are not being cloned to my Apple Watch. I get push notifications and can approve the requests, but I don’t see the accounts.

Thank you very much in advance…

Hi @borgesgj, did you give the steps in this help article a try? How to get your Duo Mobile accounts to display on Apple Watch after getting a new iPhone
Rather than reboot the phone and watch, try force quitting the Duo Mobile app on your iPhone, then your watch, and reopen the app on your phone and watch respectively.

I’m experiencing the same issue. I’ve followed those instructions and still see no accounts on my watch.

1 Like

After receiving a Duo push notification, the issue seems to have cleared up.

1 Like

@Amy yes I did with no success… however I removed the app from the watch, rebooted the watch, rebooted the phone, reinstalled the app in the watch, opened app in the phone, then in the watch and after like 10 minutes staring at both it was not syncing (that’s when I created this post and called it a day)…

So today when I got the first duo notification on the watch (which was always working) I approved it and then just by curiosity opened the app in the watch and VOILA!, I had my 2 accounts… what happened? I don’t know…

It might worth clarify that I was always getting the notifications and was able to approve them from the watch, but I was not able to see the synced accounts and also obviously couldn’t generate passcodes from the watch

Thanks for the help, and hope this can help someone else

Hmm interesting, thanks for updating your post and sharing that info with us! I will pass the message along to the mobile team to investigate.
Edit: I’m glad it’s working for you now as well!

Yes, something was wrong with the sync I guess… but yes, I’m happy for that… thanks :slight_smile:

Just want to chime in that I think there is a bug. I had the same issue with the accounts not syncing until I got a duo push notification.

I thought I’d add on here since it may help someone else. I can confirm that I fixed the problem by performing a simple edit within the app. I was experiencing almost exactly the same issue as @borgesgj after upgrading to an iPhone 12 Pro with a a series 4 watch - however no push on the watch. I tried all the above methods to rectify. I finally decided that I’d probably need to uninstall the app from my phone and add all the accounts again. Before I did that, I simply deleted one of them and readded. As soon as I did, all the accounts showed up on my watch. In fact, I think they showed up before I readded the account. So it just needed to trigger activity in the app for it to sync. :slight_smile:


Your solution worked immediately after I removed one of the accounts. Brilliant solution! I am on iPhone 12 pro as well.

1 Like

:+1: Very cool - happy to have helped! The issue was certainly driving me crazy.

I’m having the same exact issues. I upgraded my phone to 12 Pro Max and all of sudden, the Apple Watch app says no account found. I tried all of the methods suggested on here but nothing seems to work… :frowning: I’m about ready to give up and remove the app from the watch and just use the phone version instead.

Nevermind! I got it to work!

Uninstall the Duo app from the phone
Reopen the newly installed Duo app from the phone and allow push notification
Open the applewatch Duo app and it works!

Thanks everyone for chiming in here! Just wanted to give an update: The mobile team is aware of the issue and currently investigating this behavior to get to the bottom of it. Appreciate all of you sharing the steps you’ve taken, along with the workarounds that have worked for you.

I’ll update this thread when we have more info to share with you.

1 Like

@mbaydesign’s solution here worked for me… all I needed to do was to simply edit the display label names of one of the existing accounts, and then that triggered a sync and all of a sudden all of my accounts appeared on my watch!


Thank you! This was by far the easiest and most effective solution. I had same problem (new phone and watch) and all I needed to do to make them appear was edit the display label of one account - and then they all appeared.

1 Like

Glad I found this post. Upgraded to Iphone 12 Pro and had to redo the Duo for my work log in. Today I found out the Duo wasn’t working in the Apple Watch. Didn’t want to delete the app nor account because I’d need our IT Dept to resend the activation. I ended up adding a social media account in Duo and suddenly everything showed up in the Apple Watch.

Definitely a bug. Hopefully will be fixed soon.

I also was able to finally see my one accounts after editing the name of the account using the phone (ostensibly triggering a re-sync). All hail @mbaydesign.

side note: doing the whole restart phone/watch and reinstall watch app dance didn’t seem to work for me.


Same issue here - iPhone 11 with Apple Watch Series 5, Duo App on watch just randomly stopped working, showing No Accounts Found, wouldn’t even get notifications or pushes or anything.

Tried the whole reboot watch / remove app from watch etc. and nothing worked.

Thanks to @mbaydesign and @Todd_Osborne for the tips, all I did to fix was rename one of my accounts on my phone and everything sync’d back over to my watch, including the changes, and everything started working again!

1 Like

The solution is even easier than renaming an account, just move an account to change the display order on the display and Viola!