Mutiple DOU Prompts for a already existing RDP session that returns to lock screen on a timeout?

This is not a RD gateway or Terminal server this is just a straight remote desktop session

I am using the Microsoft Remote Desktop app for Windows 10 from the store
Microsoft Remote Desktop Version 10.2.1810.0

I connect to multiple servers all day and leave sessions open as I work, now that DUO has been deployed if I walk away from my desk or out to lunch I will get multiple DUO prompts and what makes it worse no info whatsoever that I could even be like yes I am on that server “allow” but its super annoying if I am on lunch break I feel like I am playing a video game with DUO prompts constantly nagging me which makes my break wonderful, I have tried both on and off for the remote desktop app option of prevent the screen from timing out

I will just say it one more time (: super annoying

How can DUO be adjusted not to do this (there is no remember me option)
Is this on the Windows Server side?

Hi @welchpat, and welcome to the Duo Community! I definitely understand your frustration, and you’re certainly not alone in this. As far as I know, there’s not a way to adjust this, and I don’t think it can be done on the Windows side either. Some good news, though, is that our team is working on a solution for this that should be out shortly. Check out this thread for more info

1 Like