Installing duo package 404

From here: Duo Unix - 2FA for SSH with PAM Support (pam_duo) | Duo Security

[duosecurity]
name=Duo Security Repository
baseurl=https://pkg.duosecurity.com/CentOS/$releasever/$basearch
enabled=1
gpgcheck=1

rpm --import https://duo.com/DUO-GPG-PUBLIC-KEY.asc

yum install duo_unix

For RHEL gives me a 404.
Do I need to replace $releasever and $basearch with system details manually? What’s the recommended way to do that if so?

Click the RHEL tab in that doc you linked:

Right right, I open that tab, create the file and run the commands from that tab and yum returns with a 404.

I’m not familiar with RHEL or yum so forgive me if this is basic.
I see now that it’s filling in those variables. Does this release just not exist for my arch?

Edited because I didn’t read the screenshot right.

What version of Red Hat are you using? Is it really 2? The oldest version for which we ever had packages was 5, and that’s not supported today.

Yeah sorry Im getting up to speed here too :smiley:
This is an EC2 instance, Amazon Linux v2. It goofed me because /etc/os-release shows “like: RHEL, CentOS fedora”

I just tried swapping the directory structure between RHEL and centOS and neither worked. So where does that leave me?

We don’t have packages for Amazon Linux. You’ll need to build from source.

ETA In addition to our docs, some sweet soul has published an Amazon Linux specific post about MFA, including Duo. You might want to take a look at that too.