Duo Ubuntu Bionic Repository?


#1

Now that Ubuntu has rolled out a new LTS release, will Duo be updating their Unix/Linux pages and add a Bionic repository? Keep in mind the Xenial repo doesn’t work at the moment:

Err:3 http://pkg.duosecurity.com/Ubuntu xenial InRelease
403 Forbidden [IP: 13.33.74.95 80]
E: Failed to fetch http://pkg.duosecurity.com/Ubuntu/dists/xenial/InRelease 403 Forbidden [IP: 13.33.74.95 80]


#2

Interested in this, currently getting 403 Forbidden and Not signed messages.

jump@jump-kubuntu:~/Downloads/duo_unix-1.10.1$ sudo apt update
Err:1 http://pkg.duosecurity.com/Ubuntu bionic InRelease
  403  Forbidden [IP: 205.251.203.175 80]
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]                               
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic InRelease                                                
Get:4 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [83.2 kB]        
Get:5 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                 
Reading package lists... Done                                 
E: Failed to fetch http://pkg.duosecurity.com/Ubuntu/dists/bionic/InRelease  403  Forbidden [IP: 205.251.203.175 80]
E: The repository 'http://pkg.duosecurity.com/Ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Here is the contents of my /etc/apt/sources.list.d/duosecurity.list file, doesn’t matter if I try the xenial or bionic release, same result.

#deb deb http://pkg.duosecurity.com/Ubuntu xenial main
deb http://pkg.duosecurity.com/Ubuntu bionic main

I have also tried sudo apt update --allow-unathenticated, but this does not work either.


#3

So, by your silence, should we assume no Ubuntu LTS release support going forward?


#4

Should we infer no support for any release of Ubuntu LTS past 16.04 or that DUO will only respond if I open a support ticket? Either way, the silence is concerning.

-Sam


#5

Hey @Mantene, @derek.smiley, and @vootrunner,

We plan to add this support in the next release of Duo Unix. I don’t have the release date yet but we’re in active development mode now.


#6

@DuoKristina - any updates on a release timeframe?


#7

@vootrunner No, I do not have any update to share. If you contact Duo Support you can ask to be added to the feature request.