Duo Security Authentication for Windows RDP issue

Duo for Windows RDP has been working flawlessly for months where I work. Recently 2 of our users are experiencing slow authentication prompt after changing their domain password. It’s now taking 25-30 seconds before the Duo authentication prompt appears after they enter their domain password. I sent the logs to support and they can’t figure it out also. Their support suck.

We uninstalled Duo, logged in with no issues. Re-installed Duo, logged in and the 25-30 sec delay persists. Had another user log in to the same machine and the same result. Blew out the user’s Duo account, uninstalled Duo from Windows, uninstalled Duo Mobile app, deleted all register/files/folder that is related to Duo. Then re-create the user’s Duo account, re-installed the application, rerolled the user, and the damn delay persists.

We almost gave up, but we tried one last thing which had a positive result. We had the user change his domain password back to his current one, and the delay went away. I am confused now… I’m not sure what could be causing the issue. Has anyone experienced this before?

Any help would be much appreciated.

Btw, I’m referring to the box that appears on the Windows login. Where it gives you multiple methods to authenticate, send push, phone call, passcode.

Hi @Ninja

I’m sorry to hear that you’re having some trouble. I am going to move your post to the Microsoft section of the community for better visibility.

Edit: Third time’s a charm… :grin: I just saw your previous post that you already sent your log to support. They will help you to investigate this further.

Thank you for using Duo!