Duo Restore not enabling

Hi there,

I’ve checked the online docs and community but wasn’t able to find an answer to my problem. I’ve had a ticket open with Duo Support for over a month but they don’t seem interested in helping.

We have Duo Restore enabled in our environment. However, when I attempt to enable it on my phone the following happens:

  1. Open Duo Mobile App
  2. Go to Menu → Settings
  3. Click on Duo Restore (currently Disabled)
  4. Click on “Backup accounts with Google Drive” to enable
  5. Get prompted for a Google account
  6. Choose a Google account
  7. Nothing happens and Duo Restore is not enabled.

Do we need to enable any APIs or safelist any apps in our Google Workspace environment to get Duo Restore working?

Cheers,
Kevin

1 Like

Hi Kevin, thanks for sharing your question here! I’m sorry to hear that you haven’t heard back from our support team regarding your case yet, and I will definitely look into that for you.

In the meantime, let me take this issue back to our mobile team and see if I can help. To answer your question:

No, this shouldn’t be the case. If you have Duo Restore enabled from the Duo Admin Panel, then taking the steps you’ve described here should work.

One clarifying question I have is, are you using Duo Mobile Instant Restore or Duo Mobile Restore (legacy)? This will help us in responding to you.

Edit: You can disregard my previous questions because as it turns out, we don’t need that info for this particular case.

Following up on this, our mobile team recently identified an issue where the Duo mobile application was bumping up against a quota during backup and restore operations. This happens during the Eastern time zone morning from around 9am to 12pm for a small number of users (~1%). The quota has since been increased, so this should no longer be an issue. Please give it a try again, and if it still not working for you, let me know so we can investigate further. It should be resolved though. I hope that helps!

Thanks for the quick reply, Amy.
Unfortunately, the problem hasn’t been resolved.

I’m running Duo Mobile version 3.59.0 Build 359000 on a Pixel 4a running Android 11.

Ok, that is unfortunate, but thank you for letting me know. We are looking into this further for you, and I’ll hopefully have some more helpful info to share soon.

A few follow-up questions for you:

  1. What time did you last attempt to enable Duo Restore? The team will use this to identify your attempt in our logs in an effort to pinpoint the error.
  2. Have you tried with another Google account, if you have one?
  3. Is the Google account you are using managed by a provider like your employer?

Also, I’ve looped in the support team, and we’re going to have the agent reach back out to you tomorrow so you can hopefully get this resolved faster than you would by working in the forum here with me. :slight_smile:

  1. The last attempt was yesterday. I’ll try again right now as well. (no luck)
  2. Yes, I have two Google accounts on my work phone and neither work.
  3. Yes, both accounts are Google Workspace accounts managed by company.

Again, thanks for the quick responses. It’s much appreciated.

1 Like

Hi again, it turns out I may have been wrong earlier when I said no to your question “Do we need to enable any APIs or safelist any apps in our Google Workspace environment to get Duo Restore working?” We’re still investigating on our end to determine whether or not this is the issue, but the relevant API is the “Drive API”. Drive is listed on this page, and it may be that the Google Workspace admin needs to whitelist our app. More to come on this.

To clarify, when you say nothing happens, you’re not seeing a dialog box with a message along the lines of Service with Google Drive is unavailable at this time. Try again later. correct? And there’s no other error message?

ETA: One last thing to check, have you disabled GDrive entirely? To test if this is the case, please try to do one of the following: access the GDrive app with the relevant account selected, save a file to the drive, or read a file there.

To clarify, when you say nothing happens, you’re not seeing a dialog box with a message along the lines of Service with Google Drive is unavailable at this time. Try again later. correct? And there’s no other error message?

That’s correct. I choose the Google account then I’m back at the “Duo Restore Settings” screen. No other dialogs, no error message.

ETA: One last thing to check, have you disabled GDrive entirely? To test if this is the case, please try to do one of the following: access the GDrive app with the relevant account selected , save a file to the drive, or read a file there.

I’m able to access Google Drive via app and browser on my phone using either Google account.

For what it’s worth, everything works fine on my personal phone using my personal GMail account.

1 Like

Thanks for testing that and letting us know! We’ll be in touch again soon… Appreciate your patience with this as well.

Hi again, following up on this - I see that you are working with Dave from our Support channel on this now. I recommend you continue to work directly with him (I shared this forum thread, and we’ve talked internally, so he has all of the details you provided here.) He’ll be able to assist you with this!

This is definitely a support issue, and we don’t normally handle those or any advanced troubleshooting here in the Duo Community since it’s a rather inefficient way to communicate on something like this, and we can’t screenshare or share any details of your environment. I was just trying to help out since our support team has been dealing with a large volume of cases lately and you hadn’t heard back.