Duo Restore Is not working between new and old iphone

I have two iPhones versions X and 12. Both running iOS 14.14.2, Both running Duo Mobile

The Duo mobile app has both personal and company apps configured. The legacy iPhone X has keychain enabled and iCloud backup enabled (Duo is configured to be included in the backup). When I enable “Reconnect Automatically” for third-party accounts, I am able to set my recovery password. I then initiate an iCloud backup.

When I restore that backup to the new iPhone and first open Duo, I do not have an option to recover the old accounts as the instructions state. My only option is to set up a new account. When I return to the original iPhone, the “reconnect automatically” has been disabled again.

My team manages the Duo environment for the company and has verified that Duo Restore is enabled for 3rd party accounts.

In summary, I am unable to restore the 3rd party apps from backup when migrating to a new iPhone after following the Duo instructions.

1 Like

Hi @bgelety, thank you for sharing your question here in the community and providing us with so much detailed information to go off of! To confirm, are your Duo-protected accounts successfully restored to your new iPhone? It is just the third-party accounts that are you having an issue with, correct?

This sounds like a known issue that the team is investigating on iOS. In the meantime, we recommend the following workaround:

Reset the feature:

  1. Enable third-party restore in the settings of Duo Mobile. Set a password.
  2. Disable third-party restore. This will reset the feature, effectively cleaning up the state that’s causing the erroneous message.

Re-enable the feature for future use:

  1. Enable third-party restore in the settings of Duo Mobile and set a password. - This is now enabled for real, and Duo Mobile will retain this password.

Please let me know if that works for you.

Thanks for the reply, Amy.

I don’t see the option to restore either the Duo-protected or the 3rd party apps on the new device.

I tried the steps you described and it still automatically disables the feature after an hour or so.

Thanks, Bob, that is good context to have. Appreciate you following up with the additional info.

I’ve shared this with our mobile team, and we are looking into it. I will follow up with you here when I have anything more to share.

Hi again, it’s unclear what could be causing this issue based on the info you have provided here. Please open a Duo Support case about this so we can investigate further. To save you from retyping all of the info you’ve shared here, I recommend linking to this post for context or mentioning that you spoke to me.