Duo Device Management work flow


#1

We have been evaluating Duo for our organization. So far it has been great!

However, I notice some tiny issue with the Duo Device Management Portal workflow and am not sure if it is is a bug or it is intended.

In the Device Management iframe, after login > click on ‘+ Add another device’ > in ‘What type of device are your adding?’, choose any from the device type and click Continue > Click Back on the next screen. Now the Back button is no longer shown for ‘What type of device are you adding’.

I find it is a little inconvenient for the user without the Back button in this case.

I am not sure if I miss anything?

Thank you.


#2

Hi quynhnng,

Are you talking about this point in the process:

Within the Device Management Portal, the only options for a user are to add a new device or modify their existing devices, which are listed as separate links under the logo (blacked out in this example). What function would you like a “Back” button to fulfill at this step in the process?

Thanks!


#3

Hi mkoroversisduo,

I am attaching some screenshots to clarify:


As you can see, there is a ‘Back’ button in the first one as you go from ‘My Settings & Devices’ to ‘Add another device’, but missing a ‘Back’ button when you go back from ‘Enter your phone number’ or whatever step after ‘What type of device are you adding’.

There are also no ‘My settings & Devices’ link in the side bar for my Device Management Portal like in your origin screenshot. (!!)

There is case such as a user just navigate around for discovering the portal, and also want to have a way to go back conveniently, and not really want to add a device. The ‘Back’ button should not be missing when going back, and should allow user to land on their ‘My Settings & Devices’ just similarly when they first go from ‘My Settings & Devices’ to ‘Add another device’.

Best Regards,


#4

Thanks for sharing this information, quynhnng. I mistakenly tested the Self-Service Portal instead of the Device Management Portal integration, as you had indicated. I will reach out to the engineering team and get back with you.


#5

Hi again quynhnng, could you please send an email to support[at]duosecurity[dot]com detailing this issue? Thanks.