DUO call me or passcode

I am new to DUO and using a trial.
When I RDP to a machine, the call me/passcode are grey out.
How to I enabled call me/passcode? I looked at the dashboard/settings, call me/passcode are all setup

thanks in advance.

Going by the screenshot, do the options become available if you click cancel? Usually, those options are disabled while the system is waiting for the Duo Push to be accepted.

1 Like

Hi @ggomez43

From what you have described here, it sounds like Auto Push is enabled. This is the installation default. Where in the dashboard/settings did you look to verify?

You can change the auto push behavior after installation by using the Registry Editor (regedit.exe) with administrator privileges to create or update the following registry value in HKEY_LOCAL_MACHINE\SOFTWARE\Duo Security\DuoCredProv:

Registry Value: AutoPush
Type: DWORD
Description: Set to 0 to disable auto-push or 1 to enable it.

Please give this a try and let me know what you find.

If this does not resolve the issue, are you using a Windows Group Policy by chance? Those settings override any changes made via regedit. You will have to update the “Client: Enable Auto Push” setting in the GPO instead. See the guide for more details: 2FA for Windows Remote Desktop Protocol and Local Logons | Duo Security

To @Julian_Diaz point, if you choose “Cancel” from the Duo Prompt when auto push is enabled, you will be able to choose a different authentication method such as a phone call or SMS passcode instead.

Hope that helps!