Duo Authentication Proxy on Raspberry Pi

In trying to install the duo auth proxy on a new Raspberry Pi 4 B+ running ubuntu server 20.04 LTS, I’ve run into an issue while building.

FIPS_text_start() returns NULL
make[2]: *** [../Makefile.shared:164: link_app.] Error 1
make[2]: Leaving directory '/home/ubuntu/openssl-1.0.2u/apps'
make[1]: *** [Makefile:157: openssl] Error 2
make[1]: Leaving directory '/home/ubuntu/openssl-1.0.2u/apps'
make: *** [Makefile:293: build_apps] Error 1

I can trace this back to this github issue, which seems to indicate lack of support for aarch64: https://github.com/openssl/openssl/issues/11105

Has anyone else had success or issues while trying to install the duo auth proxy on aarch64 / raspberry pi?

Just resurfacing this thread. Has anyone had luck with this on the raspberry pi?

Hi @Mark_Bratanov,

The 32 bit variant of Ubuntu Server for Raspberry Pi 4 will work, but the 64 bit will throw the error you’re seeing based on the OpenSSL lack of aarch64 support in the version of OpenSSL the Duo Auth Proxy utilizes (1.0.2). We don’t currently test on aarch64 and don’t plan to in future releases. You can file a feature request for official Raspberry Pi support though. Please reach out to your Account Executive or Customer Success Manager, or contact Duo Support, and they can help you with that.

1 Like

Awesome! Thanks so much Amy! I will try the 32bit variant. Thanks for your help :slight_smile:

1 Like