Duo Authentication for Windows Logon for Windows 10 1903, 1909

We are wanting to update our Duo Authentication for Windows Logon but we are using version 2.0.0.71 due to the fact that back when 1709 came out back in 2017. Is this relevant for anything past 1709? Seems as this version is no longer supported by Microsoft, the info about 1709 in the yellow box should be removed. But before I update, I want to make sure its working for current supported versions of Windows.

Thanks for your help,
Donna

Well, I locked my self out of RDP on Windows 10 about 3/4 weeks go testing DUO… It certainly worked for me, my desktop is also regularly updated (on the 1903 version) :slight_smile: Hope this helps you!

1 Like