DUO auth proxy for RDP - no authentication prompt at login


#1

DUO authentication proxy is setup for RDP purpose. However, at the RDP login screen, the DUO authentication prompt to choose the 2FA method does not appear. It only considers the factors mentioned in the authproxy.cfg file and lets or denies user login. It is preferable to get the choice at login and not sure how to enable it.


#2

Hi Ravi, if you’re trying to protect Windows systems with Duo Authentication, we recommend using our dedicated integration–documentation for which is available here: Duo Authentication for Windows Logon and RDP | Duo Security

Is there a reason why you are trying to use the authentication proxy to accomplish this?


#3

Hello,
Our windows systems have open LDAP client as primary credential provider which conflicts with DUO CP. Hence we chose DUO auth proxy which works well. However, during RDP, the authentication prompt providing 2FA options does not appear.