Duo Admin Panel to require browsers supporting TLS 1.2 beginning July 26, 2018


#1

As of July 26, 2018, access to the Duo Admin Panel will require a browser that supports the TLS 1.2 protocol. The Payment Cards Industry Security Standards Council (PCI SSC) recommends TLS 1.2 for all merchants who can collect credit card billing information. Because the Duo Admin Panel can be used for credit card billing, we have decided to adopt this requirement.

This change is not end-user facing; it will only affect Duo administrators accessing the Admin Panel on outdated browsers that do not support TLS 1.2. The newest versions of the most popular browsers all support TLS 1.2 by default. If you are concerned about compatibility, please update your browser or check your browser’s SSL implementation here: https://www.ssllabs.com.

Please let us know if you have any questions about this change.