Deploying updated versions


#1

I’m using WSUS Package Publisher for third-party updates. I’m currently running the initial 4.0 release on all workstations, and would like to update to 4.0.1. The initial release was installed manually but I’d rather not do that every time. The .msi was used for this.

On these machines, if I manually run an elevated command prompt and run “msiexec.exe /quiet /i DuoWindowsLogon64-401.msi REINSTALL=ALL REINSTALLMODE=vomus IS_MINOR_UPGRADE=1”, the install upgrades as expected. With an update approved in WPP, the computer does not find an update. I’ve tried creating the update using a transform as well as with various command line arguments (without the transform) and haven’t had any luck changing this. Any other .msi I deploy works.

Has anyone had a similar issue? Or are there log files I could look for? I tried the Windows Update log but didn’t see anything useful.


#2

I believe you’re running into a known issue with the installer. Please contact Duo Support.