I have a newly installed Exchange 2016 server on Server 2012 R2. I tried to install DUO for OWA but keep getting the error “Duo Security for OWA Integration requires ASP .NET 4.5 Enabled for IIS”. Before Exchange was installed, I had patched my servers and with that .Net 4.7.1 was installed. I went through all the prerequisites per the install documentation and all the Server options are installed for ASP 4.5. I’m not sure what else to try. Is this a compatibility issue due to having .NET 4.7.1 installed?
Do you have .NET 3.5 installed? If not, please try installing that and then retry the install.
Thanks for the suggestion. I had installed .net 3.5 through my troubleshooting, but didn’t enable the asp.net 3.5 features under the WebServer options. Once that was installed, the duo owa installer went through without error.
Hi Kristina, I have a similar issue.
After installing an Exchange CU, which raised my .NET version 4.7.0 to 4.7.2, I know that I need to reinstall Duo because Cumulative Updates reset web.config to factory.
Reinstalling Duo gave the error message about .NET version.
However, after uninstalling Duo and reinstalling, it worked just fine with 4.7.2. Which leads me to think that the issue is not a compatibility with .NET version, but some inconsistencies in detection when “updating an installation” rather than installing fresh.
I would really appreciate being able to run new Duo agent installers on top of old installations to update, rather than having to uninstall then reinstall. This is especially significant as “putting Duo config back” is a mandatory step after applying Exchange CU.
You should be able to upgrade over an existing install. Please contact Duo Support about this.