Bad Request Timestamp () [40105]

I am running a fully updated Windows 10 and trying to install the Duo agent on my VM so that I can protect RDP access to it. The MSI fails with the above error message and won’t let me continue. The api, integration code and secret key are 100% accurate. i have tried this on 3 different machines all with the same problem.

My clock is synchronised and 100% accurate to less than 1 second of deviation

I previously had this working on the same VM and started getting this error message today so I uninstalled the MSI and installed a newer version, or tried to, and now can’t complete the install.

Any ideas what is wrong? If I use https://apiURL in my browser it works fine so it can resolve the name.

Hey @ElOxle,
I assume you already read this help article “How do I resolve the error “Bad request timestamp” when using Duo Authentication for Windows Logon?” since you mention the time being in sync. That is the most common cause of this issue. If you haven’t, however, I recommend you start there! Did you try the other steps listed? For example, can you see the failed authentication attempt in the Auth Logs?

You might want to contact support for this for more formal assistance and troubleshooting. Info on how to contact Duo Support can be found on this page.