Bad Request Timestamp () [40105 Error]


#1

I am working on rolling out DUO and have come into a bit of an issue. I installed the DUO application on a Windows Server 2012R2 server (physical machine), enabled only for RDP connections. When I attempt to RDP into the server I get the following error “Bad Request Timestamp () [40105 Error]”. The network I am testing in is not in a domain, but in a workgroup. Here are the steps that I have taken so far:

  1. Ensured I has .NET 4.5 installed.
  2. Made sure time settings (NTP) were all good.
  3. Checked to make sure Windows Firewall and any other security software(s) were not blocking traffic between DUO and my network.
  4. Ensured the server has connection outside of the internal network.
    5, Also double checked username on the machine, to make sure it matched what is in DUO.

Has anyone else encountered this issue? If so, how did you resolve the issue?

Thank you in advance!


#2

Hey @NashsDad0203 thanks for starting your journey with Duo. Check out this KB for some tips. First would be checking the admin panel and looking for the failed auth attempt.


#3

Thank you for the message @PatrickKnight. When this issue initially occurred, I looked through the KB and had no luck in the resolution. Also, the logs were indicating nothing, which means there’s no communication between the server and DUO. Or that is my assumption at least. I have tried everything from disabling my firewall to creating a new local user and adding them to DUO.

Do you have any other ideas as to what I can try?


#4

If you have validated time is accurate, reviewing debug logs would be the next step.

Enable debug logs, try authenticating again and review the debug logs from this attempt.

If you continue having issue after this I’d recommend opening a case with support so we can review the logs with you.


#5

@PatrickKnight I validated that the time was correct for my location. Would that be the correct time to have my machine set too?